Mobile devices

MaintainX works best and is tested on mobile devices running the following operating systems:

  • iOS 11.0 and later

  • Android 5.0 (Lollipop) and later

Internet Browsers

MaintainX works best and is tested on the following internet browsers:

  • Chrome (Last 2 versions*)

  • Firefox (Last 2 versions*)

  • Safari 11 and later

  • Edge 17 and later

  • Opera (Latest version)

  • Internet Explorer 11 (Best effort)

*Due to their 6-week release cycles, we only support the 2 latest versions of Chrome and Firefox.

My Browser is not supported... Why is that so?

At MaintainX we take user experience and security very seriously. 

When an old browser prevents us from overhauling the security for all users, it becomes a threat to everyone. This is a risk we cannot take; we do our best to avoid that scenario by blocking older browsers.

Did this answer your question?